Windows 7 – Boot-Schleife nach klonen von HDD auf SSD

Am Wochenende war ich mal wieder zu Besuch bei meinen Eltern und habe meinem Vater auch gleich in seinem doch schon etwas betagten Windows 7 PC eine SSD eingebaut.

Um nicht unnötigerweise den Flaschenhals USB 2.0 der externen Festplatte nutzen zu müssen, habe ich auf CloneZilla gesetzt und die beiden Festplatten einfach geklont, statt das Backup von der USB-Festplatte zu aktualisieren und auf die SSD zurückzuspielen.

Normalerweise würde ich von wenigen Minuten, maximal einer Stunde bei dem vorhandenen Datenvolumen ausgehen. Leider jedoch verfing sich der PC nach dem kopieren in einer Boot-Schleife mit folgenden vor dem BSOD auftauchender Fehlermeldung:

„autochk program not found skipping autocheck“

Nach einiger Recherche bin ich dann auf diesen Beitrag gestoßen. Zwar offenbarte der Beitrag nicht die Lösung des Problems, zeigt mir aber den wichtigen Registry-Hive, wo sich die Lösung verstecken sollte.

Bei mir fehlte der Eintrag \DosDevice\C: vollständig. Einzig \DosDevice\D: war vorhanden und Ich ordnete den Laufwerksbuchstaben fälschlicherweise der C:-Partition von Windows 7 zu. Genauer gesagt: Die 100MByte große „System Recovery“ dachte ich wurde (wie in WinRE) als C:\ eingetragen und die eigentliche Windows-Partition als D:\. Dies war jedoch nicht so, klar wurde es mir, als ich den Herstellernamen des DVD-Laufwerks im Binärcode gelesen habe.

Ich fügte also einen weiteren Binary-Eintrag hinzu, benannte Ihn händisch \DosDevice\C: und fügte die korrekte Paritions-Binär-Daten ein. Diese findet Ihr weiter oben, beobachtet die fast identischen GUIDs. Da sich auf meiner SSD nur zwei Paritionen befanden und die zweite Partition davon logischerweise das „richtige“ Windows 7 war, war schnell geklärt, welche von den beiden ich übernehmen musste.

Zur Veranschaulichung habe ich das ganze bildlich festgehalten. Der untere rot umrandete Eintrag wurde von mir neu erstellt. Die Binär-Dateien habe ich dann von der zweiten Partition (orange umrandet) der Festplatte (obere rote Umrandung) kopiert und eingefügt.

dosdevice

Das einfache Löschen des gesamten Inhalts brachte bei mir leider keine Lösung. Nun startet das System aber wieder und ist dank SSD angenehm flott.

Nachtrag: Achja, die arbeiten habe ich mit der Windows 7 DVD / USB-Stick durchgeführt. Während des „Installieren“-Bildschirms, direkt nach der Länderwahl, einfach SHIFT+F10 drücken, dies öffnet eine CMD und regedit steht einem zu Verfügung. Den entsprechenden Registry-Hive muss man dann mittels „Registry laden…“ unter „D:\Windows\system32\config\SYSTEM“ öffnen.

4 Gedanken zu „Windows 7 – Boot-Schleife nach klonen von HDD auf SSD“

  1. Wow DANKE!!!
    Nach unzähligen Stunden Foren durchsuche,
    Repair Konsole starten, Einträge ändern, Bootsektor reparieren, MBR Reparieren usw. endlich DIE Lösung!
    Hast mir noch mehr frustrierte Stunden erspart!
    Danke Danke Danke

  2. Hallo Timo,

    ich habe das Problem HDD geklont und gegen SSD getauscht. Nun kommt dieser Fehler. Nur verstehe ich das nicht so ganz wie man das erkennt mit dem Laufwerk welcher Wert und wo man es einträgt.
    Könntest du das ein wenig besser umschreiben

    Viele Grüße

    SLS

    1. Moin. Sorry für die späte Rückmeldung. Wenn du mir sagst, wo du ggf. hängst, kann ich dir vielleicht helfen. Kommst du an den entsprechenden Punkt in die Registry? (siehe Bild)

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.